Back to overview
Downtime
Panel and Billing are down
Jun 24 at 09:23am EDT
Affected services
Panel - skyshomepanel.jcbm-mc.uk
Resolved
Jul 05 at 08:37pm EDT
We’re back with new link
no billing though
https://skyshomepanel.jcbm-mc.uk
Affected services
Updated
Jun 24 at 12:13pm EDT
It's because the server was mistakenly deleted. All data was unrecoverably removed. We are sorry for the inconvenience. All services are being reinstalled.
Affected services
Created
Jun 24 at 09:23am EDT
Panel and billing are currently down for unknown reasons. Please bear with us as we attempt to fix the issue.
Affected services